메뉴 바로가기 검색 및 카테고리 바로가기

한빛미디어

뇌를 자극하는 RedHat Fedora

뇌를 자극하는 RedHat Fedora 질의응답 게시판입니다.

12장 웹 서버 설치 및 운영 공부하다가 문제가 생겼습니다. (MySQL)

2014-01-19

|

by pisces218

|

snapshot1.png

1963

운영체제: 페도라 20 kde
MySQL : 5.1.71버전
아파치는 책 따라서 잘 해결이 되었습니다. 그런데 다음으로 넘어가서 해당 버전의 mysql 을 설치하니 make과정에서 오류가 발생해 5.1.73 버전으로 소스코드를 받아서 설치 완료 했습니다.

581쪽 진행 중에 Database install 문제가 생겨서 이건 공지에 있는 글 보고 해결했고  
/var/lib/mysql 경로에 mysql과 test 폴더 생성 까지는 확인 되었습니다.

그 다음 과정부터 문제가 있는데요.

첫 번째는 /web/mysql/var 경로가 없습니다. 그래서 3-6과정의 제일 마지막 명령은 건너뛰었고
두 번째는 3-7과정에서 chkconfig mysqld on 은 별다른 메시지가 나오지 않는데 service mysqld start 라고 실행을 하면
Starting MySQL.Manager of pid-file quit without updating fi[실패]
위와 같은 메시지가 나오면서 실행이 되지 않습니다.

메시지가 pid-file 어쩌고 해서 /etc/my.conf 파일에 있는 경로 (설정파일에 있는 경로는 존재하지 않았습니다.)와
같은 경로, 파일명을 생성해 주고 실행해보기도 했는데 서비스를 실행하니까 해당 결로에 만든 .pid파일도 지워지면서
실패라고 나옵니다. 해결 방법이 있나요??

그리고 소스코드말고 yum 을 이용해서 설치할 경우 경로는 어떻게 처리해줘야 하나요??
댓글 입력